忍者ブログ
カメラとバイクと自転車と
Nikonのフィルムスキャナ、COOLSCAN 4000 ED を使用している。

最近、使用中にハングしてしまうようになった。具体的には
・電源を入れているだけで、しばらくするとLEDが不規則に点滅し始める
・アプリケーションソフトからはスキャナが見えなくなる
・スキャン動作をしていない場合、もしくはDigitalICE処理中、画像の最終処理中に障害が発生すると、「スキャナの電源が入っていません」という旨のメッセージが表示される。この場合、スキャナの電源再投入でスキャナが復活すれば、引き続きスキャン動作させることができる
・スキャン動作中に障害が発生した場合、アプリが死に、そのままゾンビプロセスとなる(Windowsではゾンビなんていわないか…)。この場合、Nikon Scanを再び起動させるにはPCを再起動する必要がある。このようなひどい落ち方をするアプリケーションソフトはWindows XP においてはNikon Scan以外に他にないが、これはアプリケーションソフトかドライバの問題で、スキャナ本体のハードウェアの問題とはまた別な話。
・この障害はスキャン動作の有無には無関係に発生する。
・フィルムアダプタの種類にも無関係。何も挿入していなくとも、時間がたてば障害は確実に発生する。
・遅いときはバッチスキャンで約30コマスキャン後に発生、早いときは一コマも取り込めずに落ちることもある。

というわけで、フィルムスキャナ本体のハードウェアの故障、しかもある程度時間がたってから発生していることから、メイン基板もしくは電源回路の熱的な問題という気がする。


ためしにフィルムスキャナを分解してみる。


左右のカバーをはずすのはごく簡単。そのままの状態で電源回路にテスターを当ててみる。電源回路からは+15V、+5V、-12Vが出力されているが、電源を投入して数分待ち、障害発生状態になってから電圧を測定しても、出力電圧に変化は見られない。見た目、コンデンサなどの破損もなさそうなので、電源回路には問題がないように見える。

そのほかの基板といえば、CCDの取り付いている小さな基板のほかにはメインの大きな基板があるのみ。障害が発生しているとしたらこのメイン基板しかあるまい。というわけで取り外しを試みる。


このスキャナ、電源ラインとモーター出力、一部スイッチの配線を除き、CCD基板とメイン基板、その他との配線をすべてフレキで行っている。恐ろしく組み立てにくそうで分解もどうやっていいのやらよくわからないが、よ~~~く見ていると、分解の手順も見えてくる。

まずは電源ユニットを取り外し、すべての配線を取り外し、固定ネジをはずしてメイン基板を取り出すことに成功した。メイン基板を覆っている金属カバーをはずして現れた、コレがメイン基板。





メイン基板にはCCD制御基板らしく、三端子レギュレータがたくさん使われている。図番は6S015-064らしい。ASICが一つだけ使われている。さらに1MbitのSRAM二つ、256bitのSRAM二つ、現ルネサスのH8マイコン、TIのIEEE1394トランシーバ、フィリップスのIEEE1394リンク層コントローラ、富士通のファーム格納用フラッシュメモリ、アナデバの14bitADC、モータードライバ、その他が見える。

この状態で電源ユニットとメイン基板だけ接続し、電源を投入して様子を見る。程なくLEDが不規則に点滅を始め、障害が発生した。メイン基板と電源ユニットだけで同じ現象が再現された。電源ユニットは正常っぽいため、ほぼメイン基板の障害であるということが推定できる。


さて、誰がおかしいのでしょうか。まずは熱暴走を疑っていたので、三端子レギュレータをさわっていく。どれも多少熱を持ってはいるが、熱いというには程遠いレベル。長時間さわってみてはじめて熱を感じるくらいなので全く問題はないはず。すべてのレギュレータがそのような状態だった。レギュレータの熱は問題ないらしい。

その他のH8マイコン、IEEE1394のチップ、SRAM、いずれも信頼性に問題のありそうな部品ではない。となると、やはりニコンオリジナルのチップ、U105とふられたASICが問題ありそうだ。

ためしにASICの表面をさわって見ると、それなりに熱を持っていることがわかる。熱いというほどではないが、それなりの発熱だ。

ふと、気になって裏を見る。裏には何も実装されていない。このASIC、26x26の、フルグリッドであれば676ボールのBGAだが、パスコンはいったいどこにあるのだろうか。ASICの周囲に十数個のMLCが見えるが、たったそれだけなのだろうか。ホントに?
それで十分なのだとすればそんなに高速動作はしていないということなのだろうが(水晶は25MHz)、それにしても、大丈夫なのだろうか。

そんなこんなでメイン基板をいじってはみたが、結局原因は不明。


想像するに、ASICがもう壊れてしまっているのではないだろうか。根拠ないけど。


もうちょっときちんと確認してみますかね。。。
PR
この記事にコメントする
お名前
タイトル
メールアドレス
URL
コメント
パスワード   Vodafone絵文字 i-mode絵文字 Ezweb絵文字
この記事へのトラックバック
この記事にトラックバックする:
カレンダー
05 2017/06 07
S M T W T F S
1 2 3
4 6 7 8 9
12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30
プロフィール
HN:
butchey
性別:
男性
ブログ内検索
忍者ブログ [PR]